ScheduleFilter Class


Schedule Filter Class

A filter in a schedule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ScheduleFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleFilter : IDisposable

The ScheduleFilter type exposes the following members.

Constructors
Properties
Name Description
Public property FieldId The ID of the field used to filter the schedule.
Public property FilterType The filter type.
Public property IsDoubleValue Indicates if the filter has a double value.
Public property IsElementIdValue Indicates if the filter has an ElementId value.
Public property IsIntegerValue Indicates if the filter has an integer value.
Public property IsNullValue Indicates if the filter has no specified value.
Public property IsStringValue Indicates if the filter has a string value.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ScheduleFilter
Public method GetDoubleValue Gets the filter value for a filter using a double value.
Public method GetElementIdValue Gets the filter value for a filter using an ElementId value.
Public method GetIntegerValue Gets the filter value for a filter using an integer value.
Public method GetStringValue Gets the filter value for a filter using a string value.
Public method SetNullValue Sets the filter to have no specified value (used for HasParameter filters).
Public method SetValue(Double) Set the filter value to a double.
Public method SetValue(ElementId) Set the filter value to an ElementId.
Public method SetValue(Int32) Set the filter value to an integer.
Public method SetValue(String) Set the filter value to a string.
Top
Remarks

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.

A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.

See Also