BoundingBoxContainsPointFilter Class


Bounding Box Contains Point Filter Class

A filter used to match elements with a bounding box that contains the given point.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB BoundingBoxContainsPointFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BoundingBoxContainsPointFilter : ElementQuickFilter

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors
Name Description
Public method BoundingBoxContainsPointFilter(XYZ) Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method BoundingBoxContainsPointFilter(XYZ, Boolean) Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method BoundingBoxContainsPointFilter(XYZ, Double) Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method BoundingBoxContainsPointFilter(XYZ, Double, Boolean) Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Top
Properties
Name Description
Public property Point The XYZ point to use when matching element bounding boxes.
Public property Tolerance Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
Name Description
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also