MEPSection Class


MEPSection Class

A section in the Autodesk Revit MEP product.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical MEPSection

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPSection : IDisposable

The MEPSection type exposes the following members.

Properties
Name Description
Public property FixtureUnit The fixture unit of the section.
Public property Flow The flow of the section.
Public property Friction The friction of the section.
Public property FrictionFactor The friction factor of the section.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Number The Section number.
Public property ReynoldsNumber The Reynolds number of the section.
Public property Roughness The roughness of the section.
Public property TotalCoefficient The loss coefficient of the section.
Public property TotalCurveLength The total length of all segments in the section.
Public property TotalPressureLoss The total pressure loss of the section.
Public property Velocity The velocity of the section.
Public property VelocityPressure The velocity pressure of the section.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPSection
Public method GetCoefficient Gets the loss coefficient for the specified element id in this section.
Public method GetElementIds Gets all element ids that are contained in the section.
Public method GetPressureDrop Gets the pressure drop for the specified element id in this section.
Public method GetSegmentLength Get the length for the specified segment id in this section.
Public method IsMain Check whether the type of fitting in this section is main.
Top
Remarks
This is the base class for duct and pipe section. This class is mainly for pressure loss calculation. It is a series of connected elements (segments - ducts or pipes, fittings, terminals and accessories). All section members should have same flow analysis properties: Flow, Size, Velocity, Friction and Roughness. One section member element which contains more than one connector can belongs to multiple section. e.g.: One Tee which has 3 connectors, usually, it belongs 3 sections. One segment which connect to a tap will be divided into 2 sections.
See Also