DownloadCompanyName Method


Parameter Utils Download Company Name Method

Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string DownloadCompanyName(
	Document document,
	ForgeTypeId parameterTypeId
)

Parameters

document Document
Document in which to record the name of the parameter's owning account.
parameterTypeId ForgeTypeId
Parameter identifier.

Return Value

String
Name of the owning account.
Exceptions
Exception Condition
AccessDeniedException Thrown when the user is not authorized to access the requested information.
ArgumentException Thrown when the parameter identifier does not include an account identifier.
ArgumentNullException A non-optional argument was null
[!:Autodesk::Revit::Exceptions::NetworkCommunicationError] Thrown when communication with the remote service is unsuccessful.
ResourceNotFoundException Thrown when the requested information is not found.
ServerInternalException Thrown when the remote service reports an internal error.
UnauthenticatedException Thrown when the user is not signed in.
Remarks
In Revit, the account name appears in the parameter tooltip if available.
See Also