RoutingPreferenceManager Class


Routing Preference Manager Class

Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoutingPreferenceManager : IDisposable

The RoutingPreferenceManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OwnerId The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property PreferredJunctionType The preferred junction type.
Top
Methods
Name Description
Public method AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) Adds a new routing preference rule to the rule group.
Public method AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) Adds a new routing preference rule to the specified position in the rule group.
Public method Dispose Releases all resources used by the RoutingPreferenceManager
Public method GetMEPPartId Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method GetNumberOfRules The number of RoutingPreference rules in a group.
Public method GetRule Gets the specified rule.
Public method GetSharedSizes Gets a list of all segments of a given profile shape that define a given size.
Public method RemoveRule Removes an existing routing preference rule. Thrown if the index is out of bounds.
Top
Remarks
MEPCurveTypes contain a RoutingPreferenceManager property. The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.
See Also