GetWorksetId Method


Document Get Workset Id Method

Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public WorksetId GetWorksetId(
	ElementId id
)

Parameters

id ElementId
Id of the element.

Return Value

WorksetId
Id of the Workset which owns the element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Each element belongs to one and only one workset.
See Also