Point |
Computes outline of a part of a box that satisfies given PointCloudFilter.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- filter PointCloudFilter
- Point cloud filter.
- box Outline
- A box aligned with coordinate axes.
Return Value
OutlineThe bounding box of the set of all points within the original box that satisfy the filter. Not every point within the resulting outline satisfies the filter, but any point that is contained in the original box and satisfies the filter is guaranteed to be within the resulting outline.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |