PoissonRatio Property


Structural Asset Poisson Ratio Property

The Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ PoissonRatio { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
InapplicableDataException When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the Poisson ratio for wood-based and isotropic materials. For such assets, use setPoissonRatio instead.
See Also