RebarBendingDetail Class


Rebar Bending Detail Class

Utility class with methods needed for the bending details in view. The bending detail element has two modes -- the schematic bending detail and realistic bending detail. Some functions are exclusive to one mode.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarBendingDetail

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class RebarBendingDetail

The RebarBendingDetail type exposes the following members.

Methods
Name Description
Public method Static member AddHosts
Public method Static member Create Creates a new instance of a bending detail.
Public method Static member GetHost Gets a reference to the reinforcement element that this bending detail represents.
Public method Static member GetHosts Gets a reference to the reinforcement elements that this bending detail represents.
Public method Static member GetPosition Gets the position of the bending detail relative to its view.
Public method Static member GetRotation Gets the rotation angle in radians for the bending detail relative to its view.
Public method Static member GetTagRelativePosition Gets the embedded tag position w.r.t. the realistic bending detail element in model coordinates.
Public method Static member GetTagRelativeRotation Gets the embedded tag rotation angle w.r.t. the realistic bending detail element.
Public method Static member IsBendingDetail Checks if the input element is a bending detail.
Public method Static member IsRealisticBendingDetail Validate that the element is a realistic bending detail.
Public method Static member IsSchematicBendingDetail Validate that the element is a schematic bending detail.
Public method Static member RemoveHosts
Public method Static member ResetAnnotationPositions Resets the positions of the bending detail annotations to the default position.
Public method Static member ResetTagRelativePosition Resets the embedded tag position w.r.t. the realistic bending detail element to the selected tag position.
Public method Static member SetHost Sets the reinforcement element that will be represented by the input bending detail.
Public method Static member SetPosition Sets the position for this bending detail relative to its view.
Public method Static member SetRotation Sets the rotation angle in radians for the bending detail relative to its view.
Public method Static member SetTagRelativePosition Sets the embedded tag position w.r.t. the realistic bending detail element in model coordinates.
Public method Static member SetTagRelativeRotation Sets the embedded tag rotation angle w.r.t. the realistic bending detail element.
Top
See Also