SpotLightDistribution Class


Spot Light Distribution Class

This class encapsulates a spot light distribution.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting SpotLightDistribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SpotLightDistribution : LightDistribution

The SpotLightDistribution type exposes the following members.

Constructors
Name Description
Public method SpotLightDistribution Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution) Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double) Creates a spot light distribution object with the given values.
Top
Properties
Name Description
Public property SpotBeamAngle The spot beam angle.
Public property SpotFieldAngle The spot field angle.
Public property TiltAngle The tilt angle.
Top
Methods
Name Description
Top
See Also