Family |
Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
Back | 5 | Reference plane whose "Is Reference" parameter is set to "Back". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
Bottom | 6 | Reference plane whose "Is Reference" parameter is set to "Bottom". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
CenterElevation | 7 | Reference plane whose "Is Reference" parameter is set to "Center (Elevation)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
CenterFrontBack | 4 | Reference plane whose "Is Reference" parameter is set to "Center (Front/Back)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
CenterLeftRight | 1 | Reference plane whose "Is Reference" parameter is set to "Center (Left/Right)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
Front | 3 | Reference plane whose "Is Reference" parameter is set to "Front". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
Left | 0 | Reference plane whose "Is Reference" parameter is set to "Left". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
NotAReference | 11 | This value is returned from FamilyInstance::getReferenceType if the reference does not correspond to any reference plane or reference line in the family. |
Right | 2 | Reference plane whose "Is Reference" parameter is set to "Right". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
StrongReference | 9 | Reference plane whose "Is Reference" parameter is set to "Strong Reference", or reference line whose "Reference" parameter is set to "Strong Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive. |
Top | 8 | Reference plane whose "Is Reference" parameter is set to "Top". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive. |
WeakReference | 10 | Reference plane whose "Is Reference" parameter is set to "Weak Reference", or reference line whose "Reference" parameter is set to "Weak Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive. |