RadioButtonGroup Class


Radio Button Group Class

Represents a group of related buttons in the Ribbon.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RadioButtonGroup

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RadioButtonGroup : RibbonItem

The RadioButtonGroup type exposes the following members.

Properties
Name Description
Public property Current Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Public property Enabled Gets or sets a value indicating whether the item is enabled.
(Inherited from RibbonItem )
Public property ItemText Gets or sets the text displayed on the item.
(Inherited from RibbonItem )
Public property ItemType Gets the item type.
(Inherited from RibbonItem )
Public property LongDescription Long description of the command tooltip
(Inherited from RibbonItem )
Public property Name The name of the item.
(Inherited from RibbonItem )
Public property ToolTip The description that appears as a ToolTip for the item.
(Inherited from RibbonItem )
Public property ToolTipImage The image to show as a part of the button extended tooltip
(Inherited from RibbonItem )
Public property Visible Gets or sets a value indicating whether the item is visible.
(Inherited from RibbonItem )
Top
Methods
Name Description
Public method AddItem Adds a new ToggleButton to the RadioButtonGroup.
Public method AddItems
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from RibbonItem )
Public method GetContextualHelp Gets the contextual help bound with this control.
(Inherited from RibbonItem )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetItems Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetContextualHelp Sets the contextual help bound with this button.
(Inherited from RibbonItem )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This class contains a collection of ToggleButtons. Only one of the ToggleButtons will appear active at a given time. When a different button is clicked in the UI the current ToggleButton will be changed, and the ToggleButton's external command will be invoked. Use of this class is not supported in Revit Macros.
See Also