RadioButtonGroup Class


Radio Button Group Class

Represents a group of related buttons in the Ribbon.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RadioButtonGroup

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RadioButtonGroup : RibbonItem

The RadioButtonGroup type exposes the following members.

Properties
Name Description
Public property Current Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Top
Methods
Name Description
Public method AddItem Adds a new ToggleButton to the RadioButtonGroup.
Public method AddItems
Public method GetItems Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
Top
Remarks
This class contains a collection of ToggleButtons. Only one of the ToggleButtons will appear active at a given time. When a different button is clicked in the UI the current ToggleButton will be changed, and the ToggleButton's external command will be invoked. Use of this class is not supported in Revit Macros.
See Also