Panel Class


Panel Class

This object represents a curtain panel.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Panel : FamilyInstance

The Panel type exposes the following members.

Properties
Name Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property CanFlipFacing Property to test whether the orientation of family instance facing can be flipped.
(Inherited from FamilyInstance )
Public property CanFlipHand Property to test whether the orientation of family instance hand can be flipped.
(Inherited from FamilyInstance )
Public property CanFlipWorkPlane Identifies if the instance can flip its work plane.
(Inherited from FamilyInstance )
Public property CanRotate Property to test whether the family instance can be rotated by 180 degrees.
(Inherited from FamilyInstance )
Public property CanSplit Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double) ).
(Inherited from FamilyInstance )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property ExtensionUtility Property to check whether the instance can be extended and return the interface for extension operation.
(Inherited from FamilyInstance )
Public property FacingFlipped Property to test whether the orientation of family instance facing is flipped.
(Inherited from FamilyInstance )
Public property FacingOrientation Property to get the orientation of family instance facing.
(Inherited from FamilyInstance )
Public property FromRoom The "From Room" set for the door or window in the last phase of the project.
(Inherited from FamilyInstance )
Public property FromRoom Phase
(Inherited from FamilyInstance )
Public property Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property HandFlipped Property to test whether the orientation of family instance hand is flipped.
(Inherited from FamilyInstance )
Public property HandOrientation Property to get the orientation of family instance hand.
(Inherited from FamilyInstance )
Public property HasSpatialElementCalculationPoint Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
(Inherited from FamilyInstance )
Public property HasSpatialElementFromToCalculationPoints Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
(Inherited from FamilyInstance )
Public property Host If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
(Inherited from FamilyInstance )
Public property HostFace Property to get the reference to the host face of family instance.
(Inherited from FamilyInstance )
Public property HostParameter If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
(Inherited from FamilyInstance )
Public property Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property Invisible Property to test whether the family instance is invisible.
(Inherited from FamilyInstance )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsSlantedColumn Indicates if the family instance is a slanted column.
(Inherited from FamilyInstance )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property IsWorkPlaneFlipped Identifies if the instance's work plane is flipped.
(Inherited from FamilyInstance )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Location This property is used to find the physical location of an instance within project.
(Inherited from FamilyInstance )
Public property Lockable This property is used to know whether a panel can be locked.
Public property MEPModel Retrieves the MEP model for the family instance.
(Inherited from FamilyInstance )
Public property Mirrored Property to test whether the family instance is mirrored. (only one axis is flipped)
(Inherited from FamilyInstance )
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property PanelType The Panel style of this Panel.
Public property Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property Room The room in which the instance is located (during the last phase of the project).
(Inherited from FamilyInstance )
Public property Room Phase
(Inherited from FamilyInstance )
Public property Space The space in which the instance is located (during the last phase of the project).
(Inherited from FamilyInstance )
Public property Space Phase
(Inherited from FamilyInstance )
Public property StructuralMaterialId Identifies the material that defines the instance's structural analysis properties.
(Inherited from FamilyInstance )
Public property StructuralMaterialType This property returns the physical material from which the instance is made.
(Inherited from FamilyInstance )
Public property StructuralType Provides the primary structural type of the instance, such as beam or column etc.
(Inherited from FamilyInstance )
Public property StructuralUsage Provides the primary structural usage of the instance, such as brace, girder etc.
(Inherited from FamilyInstance )
Public property SuperComponent Property to get the super component of current family instance.
(Inherited from FamilyInstance )
Public property Symbol Returns or changes the FamilySymbol object that represents the type of the instance.
(Inherited from FamilyInstance )
Public property ToRoom The "To Room" set for the door or window in the last phase of the project.
(Inherited from FamilyInstance )
Public property ToRoom Phase
(Inherited from FamilyInstance )
Public property Transform This property is used to find the transform of a curtain panel within project.
Public property UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method AddCoping Adds a coping (cut) to a steel beam.
(Inherited from FamilyInstance )
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues
(Inherited from Element )
Public method FindHostPanel Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method flipFacing The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
(Inherited from FamilyInstance )
Public method FlipFromToRoom Flips the settings of "From Room" and "To Room" for the door or window instance.
(Inherited from FamilyInstance )
Public method flipHand The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
(Inherited from FamilyInstance )
Public method GetCopingIds Lists the elements currently used as coping cutters for this element.
(Inherited from FamilyInstance )
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetFamilyPointPlacementReferences Returns the Point Placement References for the Family Instance.
(Inherited from FamilyInstance )
Public method GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetOriginalGeometry Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
(Inherited from FamilyInstance )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetReferenceByName Gets the family instance reference corresponding to the named reference plane in the instance's family.
(Inherited from FamilyInstance )
Public method GetReferenceName Gets the name of the reference plane in the family corresponding to the given family instance reference.
(Inherited from FamilyInstance )
Public method GetReferences Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
(Inherited from FamilyInstance )
Public method GetReferenceType Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
(Inherited from FamilyInstance )
Public method GetRefGridLines This method is used to get the reference gridlines.
Public method GetSpatialElementCalculationPoint Gets the location of the calculation point for this instance.
(Inherited from FamilyInstance )
Public method GetSpatialElementFromToCalculationPoints Gets the locations for the calculation points for this instance.
(Inherited from FamilyInstance )
Public method GetSubComponentIds Gets the sub component ElementIds of the current family instance.
(Inherited from FamilyInstance )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetSweptProfile Gets the object that describes the profile that is swept along the driving curve for this instance.
(Inherited from FamilyInstance )
Public method GetTotalTransform Gets the total transform, which includes the true north transform for instances like import instances.
(Inherited from Instance )
Public method GetTransform Gets the transform of the instance.
(Inherited from Instance )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasModifiedGeometry Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
(Inherited from FamilyInstance )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method HasSweptProfile Indicates if this instance can be represented as a swept profile.
(Inherited from FamilyInstance )
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method RemoveCoping Removes a coping (cut) from a steel beam.
(Inherited from FamilyInstance )
Public method rotate The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
(Inherited from FamilyInstance )
Public method SetCopingIds
(Inherited from FamilyInstance )
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method Split Splits the family instance element at a point on its defining curve.
(Inherited from FamilyInstance )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also