IsValidReferenceCurve Method


Direct Shape Type Is Valid Reference Curve Method

Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidReferenceCurve(
	Curve curve
)

Parameters

curve Curve
The curve to test.

Return Value

Boolean
True if the input curve point can be used to create a direct shape reference curve, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also