GetSpaceAtPoint Method (XYZ, Phase)


Document Get Space At Point(XYZ, Phase) Method

Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Space GetSpaceAtPoint(
	XYZ point,
	Phase phase
)

Parameters

point XYZ
Point to be checked.
phase Phase
Phase in which the space exists.

Return Value

Space
The space containing the point.
Exceptions
Exception Condition
ArgumentNullException Thrown when the point is .
ArgumentException Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
If phase is , it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns .
See Also