MemberForces Class


Member Forces Class

An object that represents a member forces on analytical element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure MemberForces

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MemberForces : IDisposable

The MemberForces type exposes the following members.

Constructors
Name Description
Public method MemberForces Creates a new instance of MemberForces.
Top
Properties
Name Description
Public property Force The translational forces at relative point position of the element.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Moment The rotational forces at relative point position of the element.
Public property Start Member Forces position on analytical element. True for start, false for end.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MemberForces
Top
See Also