Exporter |
This sets the material id that is to be associated with the element in the current export state.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- elementId ElementId
- The material id.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.