SetHostId Method


Rebar Container Set Host Id Method

The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetHostId(
	Document doc,
	ElementId hostId
)

Parameters

doc Document
The document containing both this element and the host element.
hostId ElementId
The element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column. The rebar does not need to be strictly inside the host, but it must be assigned to one host element.
Exceptions
Exception Condition
ArgumentException hostId is not a legal Rebar Container host.
ArgumentNullException A non-optional argument was null
See Also