Revolved |
Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- frameOfReference Frame
- frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
- The frame can be "right-handed" or "left-handed".
- The origin of the frame is the base of point of the axis of revolution.
- The BasisZ of the frame is the direction of the axis.
- profileCurve Curve
- The profile curve.
Return Value
BooleanTrue if the profile curve is valid; False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The validity is defined as follows:
- The profile curve is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on the xz plane of the frame.
- It lies on the right side of the axis.
- Only the end points of the profile curve can touch the axis.