ElementParameterFilter Class


Element Parameter Filter Class

A filter used to match elements by one or more parameter filter rules.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementParameterFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementParameterFilter : ElementSlowFilter

The ElementParameterFilter type exposes the following members.

Constructors
Name Description
Public method ElementParameterFilter(FilterRule) Constructs a new instance of an ElementParameterFilter from a single rule.
Public method ElementParameterFilter(IList FilterRule ) Initializes a new instance of the ElementParameterFilter class
Public method ElementParameterFilter(FilterRule, Boolean) Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method ElementParameterFilter(IList FilterRule , Boolean) Initializes a new instance of the ElementParameterFilter class
Top
Properties
Name Description
Top
Methods
Name Description
Public method GetRules Returns the set of rules contained in this filter.
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also