ElementParameterFilter Class


Element Parameter Filter Class

A filter used to match elements by one or more parameter filter rules.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementParameterFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementParameterFilter : ElementSlowFilter

The ElementParameterFilter type exposes the following members.

Constructors
Name Description
Public method ElementParameterFilter(FilterRule) Constructs a new instance of an ElementParameterFilter from a single rule.
Public method ElementParameterFilter(IList FilterRule ) Initializes a new instance of the ElementParameterFilter class
Public method ElementParameterFilter(FilterRule, Boolean) Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method ElementParameterFilter(IList FilterRule , Boolean) Initializes a new instance of the ElementParameterFilter class
Top
Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRules Returns the set of rules contained in this filter.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also