FailureDefinition Class


Failure Definition Class

Defines persistent information about a failure.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailureDefinition : IDisposable

The FailureDefinition type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Severity The severity of the failure.
Top
Methods
Name Description
Public method AddResolutionType Adds a type of possible resolution for the failure.
Public method Static member Code example CreateFailureDefinition Creates an instance of a FailureDefinition.
Public method Dispose Releases all resources used by the FailureDefinition
Public method GetApplicableResolutionTypes Retrieves a list of resolution types applicable to the failure.
Public method GetDefaultResolutionType Retrieves the default resolution type for the failure.
Public method GetDescriptionText Retrieves the description text of the failure.
Public method GetResolutionCaption Retrieves the caption for a specific resolution type.
Public method HasResolutions Checks if the FailureDefinition has at least one resolution.
Public method IsResolutionApplicable Checks if the given resolution type is applicable to the failure.
Public method SetDefaultResolutionType Sets the default resolution type for the failure.
Top
Remarks
Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.
See Also