Text |
Options to use when creating a new text note element.

System Object
Autodesk.Revit.DB TextNoteOptions
Autodesk.Revit.DB TextNoteOptions
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The TextNoteOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | TextNoteOptions | Default constructor; populates the options with their respective default values. |
![]() | TextNoteOptions(ElementId) | Constructs text options to create text of the given type. |

Name | Description | |
---|---|---|
![]() | HorizontalAlignment | Horizontal alignment of the text. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable. |
![]() | Rotation | Base line angle of a text note, in radians. |
![]() | TypeId | Id of a text type that defines the style of a text note. |
![]() | VerticalAlignment | Vertical alignment of the text. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TextNoteOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Use an instance of this class as an argument in the TextNote.Create methods.