Project |
Create an instance of ProjectLocation in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ProjectLocation Create(
Document document,
ElementId siteLocationId,
string name
)
Parameters
- document Document
- The document where the new instance of ProjectLocation would be created in.
- siteLocationId ElementId
- The ElementId of the SiteLocation to which the new ProjectLocation would be created.
- name String
- The name of the instance of ProjectLocation to be created.
Return Value
ProjectLocationThe newly created instance of ProjectLocation.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The element siteLocationId does not exist in the document -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- There is already a ProjectLocation with this name in the given SiteLocation. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The created instace of ProjectLocation would have the specified name and an identity Transform .