ThermalExpansionCoefficient Property


Structural Asset Thermal Expansion Coefficient Property

The thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ ThermalExpansionCoefficient { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
InapplicableDataException When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the thermal expansion coefficient for wood-based and isotropic materials. For such assets, use setThermalExpansionCoefficient instead. The value is in inverse Kelvin (1/K).
See Also