Rebar |
Return a transform representing the relative position of any individual bar in the set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- barPositionIndex Int32
- An index between 0 and (NumberOfBarPositions-1).
Return Value
TransformThe position of a bar in the set relative to the first position.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |
InvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |

The transform is a translation along the distribution path. It can be applied to the results of GetCenterlineCurves() to produce any bar in the rebar set. For barPositionIndex=0, the identity transform is always returned.