AddSubFolder Method


External Resource Browser Data Add Sub Folder(String) Method

Adds a subfolder to the folder path with the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddSubFolder(
	string folderName
)

Parameters

folderName String
The name of the folder.
Exceptions
Exception Condition
ArgumentException The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
ArgumentNullException A non-optional argument was null
See Also