Construction Class


Construction Class

Construction definition for Project Information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Construction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Construction

The Construction type exposes the following members.

Properties
Name Description
Public property Id Get the id of the Construction.
Public property Name Get the name of the Construction.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This is used to define the information in Constructions.xml.
See Also