IFCFamilyInstanceExtrusionExportResults Class


IFCFamily Instance Extrusion Export Results Class

This class represents the results of a geometric analysis of a family instance.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCFamilyInstanceExtrusionExportResults

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCFamilyInstanceExtrusionExportResults : IDisposable

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Properties
Name Description
Public property ExtraOffset The extra offset determined from the geometry of the family instance.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaterialId The best material id determined for the family instance.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCFamilyInstanceExtrusionExportResults
Public method GetCutPairOpenings Gets the set of "openings" determined from the analysis of the instance geometry.
Public method GetExtrusionHandle Gets the extruded solid handle generated for the family instance.
Top
Remarks
The analysis attempts to convert the geometry of the instance into a single extrusion with additional extruded openings cutting the main solid.
See Also