BuiltInFailures.OverlapFailures Class


Built In Failures Overlap Failures Class

Failures detected by overlap check.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures OverlapFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class OverlapFailures

The BuiltInFailures OverlapFailures type exposes the following members.

Properties
Name Description
Public property Static member AreaBoundaryLinesOverlap Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
Public property Static member CurvesOverlap Highlighted lines overlap. Lines may not form closed loops.
Public property Static member DivisionSketchOverlap Curves in the sketch of the Division overlap.
Public property Static member DuplicateFabricSheet There are identical Fabric sheets in the same place. This will result in double counting in schedules.
Public property Static member DuplicateInstances There are identical instances in the same place. This will result in double counting in schedules.
Public property Static member DuplicatePoints There are identical points in the same place. Lines created from points may not work as expected.
Public property Static member DuplicateRebar There are identical rebar in the same place. This will result in double counting in schedules.
Public property Static member ELASeparationLinesOverlap Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
Public property Static member FloorsOverlap Highlighted floors overlap.
Public property Static member LevelsOverlap Highlighted levels overlap.
Public property Static member OverlappingElementsTest There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
Public property Static member RoomSeparationLinesOverlap Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
Public property Static member SpaceSeparationLinesOverlap Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
Public property Static member SubregionOverlap Highlighted sub-division overlap.
Public property Static member ToposolidFloorOverlap Highlighted toposolid and floor overlap.
Public property Static member ToposolidOverlap Highlighted toposolid overlap.
Public property Static member ToposolidSubregionOverlap Highlighted toposolid and sub-division overlap.
Public property Static member WallAreaBoundaryOverlap Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
Public property Static member WallRoomSeparationOverlap A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
Public property Static member WallsOverlap Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
Public property Static member WallSpaceSeparationOverlap A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.
Top
See Also