BuiltInFailures.WallJoinRoofFailures Class


Built In Failures Wall Join Roof Failures Class

Failures about WallJoinRoof.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures WallJoinRoofFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class WallJoinRoofFailures

The BuiltInFailures WallJoinRoofFailures type exposes the following members.

Properties
Name Description
Public property Static member NoFromRoofForWall Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
Public property Static member NotCoveredAtAllByTarget Highlighted walls are attached to, but miss, the highlighted targets.
Public property Static member NoUptoRoofForWall Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
Public property Static member WallMeetsRoofTangentially The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
Public property Static member WallNotCoveredByRoof The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).
Top
See Also