EnableUpdater Method


Updater Registry Enable Updater Method

Enables the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void EnableUpdater(
	UpdaterId id
)

Parameters

id UpdaterId
The updater id.
Exceptions
Exception Condition
ArgumentException Updater with this Id is not currently registered in Revit.
ArgumentNullException A non-optional argument was null
Remarks
Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.
See Also