IsPerspective Property


View 3D Is Perspective Property

Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsPerspective { get; }

Property Value

Boolean
Exceptions
Exception Condition
InvalidOperationException Returns true if the view is not a view template.
Remarks
In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The property ViewDirection becomes less meaningful - it only describes the general orientation of the camera.
See Also