MoveNext Method


Definition Binding Map Iterator Move Next Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual bool MoveNext()

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator MoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also