TableView Class


Table View Class

This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TableView : View

The TableView type exposes the following members.

Properties
Name Description
Public property MaximumColumnWidth Gets the maximum column width
Public property MaximumGridWidth Gets the allowed maximum grid width
Public property MaximumRowHeight Gets the maximum row height
Public property MinimumColumnWidth Gets the minimum column width
Public property MinimumRowHeight Gets the minimum row height
Public property TargetId the element id of the element that is being viewed
Top
Methods
Name Description
Public method GetAvailableParameterCategories Get all available parameter categories.
Public method Static member GetAvailableParameters Gets a list of valid parameters for the specified category that can be used in the table view.
Public method GetCalculatedValueName Gets the calculated value name for a cell from the template view.
Public method GetCalculatedValueText Gets the calculated value text for a cell from the instance view.
Public method GetCellText Gets the cell's text based on its type
Public method IsValidSectionType Identifies if the section type is valid for this view.
Top
See Also