CircuitConnectionType Property


Electrical System Circuit Connection Type Property

The circuit connection type of the electrical system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CircuitConnectionType CircuitConnectionType { get; set; }

Property Value

CircuitConnectionType
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: The connection type is invalid for this circuit. You can't assign Feed Through Lugs if the panel's Feed Through Lugs option is unchecked. If the circuit's base panel is not a data panel or transformer panel, the circuit connection type can't be set to NotApplicable. If the circuit's base panel is a data panel or transformer pane, it must be set to NotApplicable. If the circuit doesn't have a base panel, it must be set to NotApplicable. -or- When setting this property: Invalid connection type.
See Also