JournalData Property


External Command Data Journal Data Property

A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IDictionary<string, string> JournalData { get; set; }

Property Value

IDictionary String , String
Remarks
The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.
See Also