BalusterPattern Class


Baluster Pattern Class

Baluster pattern class.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Architecture BalusterPattern

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BalusterPattern : IDisposable

The BalusterPattern type exposes the following members.

Properties
Name Description
Public property BreakPattern The condition which controls breaking baluster patterns distribution.
Public property DistributionJustification Determines how baluster pattern distribution is justified.
Public property EndSpace The extra space added after a whole baluster pattern.
Public property ExcessLengthFillBalusterId The id of a Baluster family used to fill excess length, which is the extra space along the railing segment that cannot be filled with a pattern. If set to InvalidElementId, it will be the default - the id of the BaseRailingAttr containing the Baluster pattern.
Public property ExcessLengthFillSpacing The value defines the spacing between each baluster instance inserted in the excess length.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Length The length of the main baluster pattern.
Public property PatternAngle The angle between neighboring railing segments which conditions breaking patterns distribution along a railing path.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BalusterPattern
Public method DuplicateBaluster Duplicates the baluster pointed by given index in the main baluster pattern.
Public method GetBaluster Gets information about the given baluster from the main baluster pattern.
Public method GetBalusterCount Gets the number of balusters in the main baluster pattern definition.
Public method RemoveBaluster Removes a baluster from the main baluster pattern.
Top
See Also