BuiltInFailures.RenderFailures Class


Built In Failures Render Failures Class

Failures related to rendering.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures RenderFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RenderFailures

The BuiltInFailures RenderFailures type exposes the following members.

Properties
Name Description
Public property Static member LightParametersNotInRange The value should be in range of [Value] and [Value].
Public property Static member LightSourceInsideGeometry Light source is inside solid geometry. No light will be emitted during rendering.
Public property Static member ProhibitDeletionLightSource The light source cannot be deleted with UI.
Public property Static member RenderLibNotInstalledWarn Rendering library has not been installed, so the third party geometry cannot be created.
Top
See Also