RebarLayoutRule Enumeration


Rebar Layout Rule Enumeration

The rule for how the rebars in rebar set are laid out

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarLayoutRule
Members
Member name Value Description
FixedNumber 1 The spacing between the rebar is adjustable, but the number of bars is constant based on input.
MaximumSpacing 2 The maximum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set.
MinimumClearSpacing 4 The minimum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set. This spacing is maintained even if the rebar size changes.
NumberWithSpacing 3 Both the spacing between rebar and the number of rebar are constant based on input.
Single 0 It is a single rebar and not a rebar set.
See Also