Create Method


View Sheet Create Method

Creates a new ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ViewSheet Create(
	Document document,
	ElementId titleBlockTypeId
)

Parameters

document Document
The document to which the ViewSheet will be added.
titleBlockTypeId ElementId
The type id of the TitleBlock type which will be used by the new ViewSheet. For no TitleBlock, pass invalid element ID.

Return Value

ViewSheet
The new ViewSheet.
Exceptions
Exception Condition
ArgumentException The ElementId titleBlockTypeId does not correspond to a TitleBlock type. -or- document is not a project document.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also