ElementDesignOptionFilter Class


Element Design Option Filter Class

A filter used to find elements contained within a particular design option.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementDesignOptionFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementDesignOptionFilter : ElementQuickFilter

The ElementDesignOptionFilter type exposes the following members.

Constructors
Name Description
Public method ElementDesignOptionFilter(ElementId) Constructs a new instance of a filter to match elements contained within a particular design option.
Public method ElementDesignOptionFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.
Top
Properties
Name Description
Public property DesignOptionId The design option id.
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also