GetSplittingElements Method


Part Utils Get Splitting Elements Method

Identifies the elements ( reference planes, levels, grids ) that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ISet<ElementId> GetSplittingElements(
	Document document,
	ElementId partId
)

Parameters

document Document
The source document of the part.
partId ElementId
The part id.

Return Value

ISet ElementId
The elements that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also