RebarFreeFormAccessor Class


Rebar Free Form Accessor Class

A class that is used to access the properties and capabilities of free-form Rebar.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarFreeFormAccessor

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarFreeFormAccessor : IDisposable

The RebarFreeFormAccessor type exposes the following members.

Properties
Name Description
Public property AlignedFreeFormSetOrientationOptions Orientation options for an Aligned Free Form Rebar set.
Public property CycleCounter

Identifies the cycle counter. It can be zero or a pozitive number.

Its value is changed when the free form Rebar element is selected and the user press Space key -or- through the setter of this property -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0). This property can be accessed just for Rebars that are controlled by a server.

Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property RebarStyle Identifies the RebarStyle of the current Rebar element.
Public property StirrupTieAttachmentType Identifies the StirrupTieAttachmentType of the current Rebar element. The RebarStyle of the Rebar element must be StirrupTie.
Public property WorkshopInstructions Identifies the workshop instructions of the current Rebar element.
Top
Methods
Name Description
Public method AddUpdatingSharedParameter Add existing shared parameter as a dependency for the calculation of the rebar curves.
Public method CanBeHookNormal A vector can be hook normal if for a bar specified by index, the bar direction is not parallel with the vector.
Public method DisconnectFromServer Sets the GUID of the API server to invalid value and removes all the server related data from the Rebar (ex. the current constraints and the handle tags are removed). Calling this method will result in a Rebar that will not react to host changes anymore, however it will still have all the properties that it used to have.
Public method Dispose Releases all resources used by the RebarFreeFormAccessor
Public method GetCouplerIdAtIndex Gets the id of the Rebar Coupler that is applied to the bar with index barPositionIndex at the specified end.
Public method GetCustomDistributionPath Gets the custom distribution path for free form rebar set.
Public method GetEndTreatmentTypeIdAtIndex Gets the id of the EndTreatmentType that is applied to the bar with index barPositionIndex at the specified end.
Public method GetHookOrientationAngle Get the hook orientation angle at end.
Public method GetHookOrientationAngleAtIndex Gets the hook orientation angle that is applied to this Rebar at the bar with index barPositionIndex at the specified end.
Public method GetHookOrientationAtIndex Gets the hook orientation that is applied to this Rebar at the bar with index barPositionIndex at the specified end.
Public method GetHookPlaneNormalForBarIdx Returns the normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Public method GetHookTypeIdAtIndex Gets the id of the RebarHookType that is applied to this Rebar at the bar with index barPositionIndex at the specified end.
Public method GetServerGUID Returns the GUID of the API server.
Public method GetShapeIdAtIndex Gets the Rebar Shape id for the bar with index barPositionIndex.
Public method GetUpdatingSharedParameters Get the shared parameters listed as dependencies in the calculation of the rebar curves
Public method HasValidAlignedServer Returns true if the current rebar is created with the Aligned Free Form rebar server, false otherwise.
Public method HasValidServer Returns true if the current rebar contains a valid server GUID, false otherwise.
Public method IsBarMatchedWithShapeInReverseOrder Checks if the bar at index barPositionIndex it's matched in reversed order with its shape.
Public method IsUnconstrained Returns true if the current rebar doesn't contains a valid server GUID, or contains a valid server GUID and no valid constraints.
Public method RemoveUpdatingSharedParameter Remove existing shared parameter as a dependency for the calculation of the rebar curves.
Public method SetCurves(IList CurveLoop )
Public method SetCurves(IList IList Curve )
Public method SetHookOrientationAngle Set the hook orientation angle at end. Will throw exception if the rebar has valid constraints.
Public method SetHookPlaneNormalForBarIdx Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.
Public method SetLayoutAsFixedNumber Sets the Layout Rule property of rebar set to Fixed Number.
Public method SetLayoutAsMaximumSpacing Sets the Layout Rule property of rebar set to Maximum Spacing.
Public method SetLayoutAsMinimumClearSpacing Sets the Layout Rule property of rebar set to Minimum Clear Spacing.
Public method SetLayoutAsNumberWithSpacing Sets the Layout Rule property of rebar set to Number With Spacing.
Public method SetLayoutAsSingle Sets the Layout Rule property of rebar set to Single.
Public method SetReportedShape This method changes the RebarShape of a Free Form Rebar that is using RebarWorkInstructions.Straight property to the provided RebarShape.
Top
Remarks
Obtain an instance of this class from GetFreeFormAccessor . The accessor includes a reference to the Rebar element. If the referenced Rebar element is deleted, using the methods form this class will throw exception.
See Also