Mesh Class


Mesh Class

A triangular mesh.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Mesh : GeometryObject

The Mesh type exposes the following members.

Properties
Name Description
Public property DistributionOfNormals Indicates the distribution of normal vectors along the tessellated mesh surface.
Public property IsClosed Indicates whether the mesh is closed.
Public property MaterialElementId Element ID of the material from which this mesh is composed.
Public property NumberOfNormals The number of normals associated with the mesh.
Public property NumTriangles The number of triangles that the mesh contains.
Public property Transformed Transforms this mesh and returns the result.
Public property Triangle Retrieves a specific triangle.
Public property Vertices Retrieves all vertices used to define this mesh. Intended for indexed access.
Top
Methods
Name Description
Public method ComputeSurfaceArea Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method GetNormal Returns a normal unit vector at the given index.
Public method GetNormals Returns all normals assigned to the mesh.
Top
Remarks
Meshes are generated during triangulation of faces. They can also be encountered directly in Revit geometry (typically imported geometry). Meshes contain a single array of Vertices , and a corresponding array of triangles. Triangles can be accessed by index from Triangle Int32 , and reference 3 vertices from the Vertices array.
See Also