Create Method (Connector, ElectricalSystemType)


Electrical System Create(Connector, Electrical System Type) Method

Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElectricalSystem Create(
	Connector connector,
	ElectricalSystemType elecSysType
)

Parameters

connector Connector
The Connector to create this Electrical System.
elecSysType ElectricalSystemType
The System Type of electrical system.

Return Value

ElectricalSystem
If successful a new MEP Electrical System element within the project, otherwise .
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also