ToElementIds Method


Filtered Element Collector To Element Ids Method

Returns the complete set of element ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> ToElementIds()

Return Value

ICollection ElementId
The complete set of element ids.
Exceptions
Exception Condition
InvalidOperationException The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also