DirectShape Class


Direct Shape Class

This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB DirectShape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DirectShape : Element

The DirectShape type exposes the following members.

Properties
Name Description
Public property ApplicationDataId A text string that identifies the data to the creating application.
Public property ApplicationId A text string that identifies the creating application.
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property TypeId Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
Public property UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method AddExternallyTaggedGeometry Adds the externally tagged geometry object to the DirectShape.
Public method AddReferenceCurve(Curve) Adds a reference curve to the DirectShape.
Public method AddReferenceCurve(Curve, DirectShapeReferenceOptions) Adds a reference curve to the DirectShape.
Public method AddReferencePlane(Plane) Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method AddReferencePlane(Plane, BoundingBoxUV) Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method AddReferencePlane(Plane, DirectShapeReferenceOptions) Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method AddReferencePoint(XYZ) Adds a reference point to the DirectShape.
Public method AddReferencePoint(XYZ, DirectShapeReferenceOptions) Adds a reference point to the DirectShape.
Public method AppendShape(IList GeometryObject )
Public method AppendShape(ShapeBuilder) Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method AppendShape(IList GeometryObject , DirectShapeTargetViewType)
Public method AreOptionsValid Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method AreOptionsValidForTransientDirectShape Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method AreValidDirectShapeReferenceOptions Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanCreateParts Indicates if it is possible to create parts from this DirectShape element.
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method Static member CreateElement Creates a DirectShape object and adds it to document.
Public method Static member CreateElementInstance Creates a DirectShape object and adds it to document.
Public method Static member CreateGeometryInstance Creates a copy of a definition shape that was created earlier.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues
(Inherited from Element )
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternallyTaggedGeometry Gets the externally tagged geometry by its external ID that is stored in this DirectShape.
Public method GetExternallyTaggedReference Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOptions Gets a copy of the current options for this DirectShape.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method HasExternalGeometry Checks whether the externally tagged geometry is already present in this DirectShape.
Public method HasExternallyTaggedReference Checks if the externally tagged reference is already present in this DirectShape.
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method Static member IsSupportedDocument Tests whether a DirectShape or a DirectShapeType may be created in this document.
Public method Static member IsValidCategoryId Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method IsValidGeometry Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
Public method Static member IsValidReferenceCurve Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
Public method Static member IsValidReferencePlaneBoundingBoxUV Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method IsValidShape(ExternallyTaggedGeometryObject) Validates shape to be stored in a DirectShape.
Public method IsValidShape(IList GeometryObject )
Public method IsValidShape(IList GeometryObject , DirectShapeTargetViewType)
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method IsValidTypeId Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method IsValidUsage Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method RemoveAllReferenceObjects Removes all reference objects (if any) from the DirectShape.
Public method RemoveExternallyTaggedGeometry Removes the externally tagged geometry object by its external ID from this DirectShape.
Public method RemoveReferenceObject(ExternalGeometryId) Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method RemoveReferenceObject(String) Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method ResetExternallyTaggedGeometry Removes all of the externally tagged geometry in this DirectShape.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method SetName Sets the name for the DirectShape element.
Public method SetOptions Sets the options to use for this DirectShape.
Public method SetShape(IList GeometryObject )
Public method SetShape(ShapeBuilder) Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method SetShape(IList GeometryObject , DirectShapeTargetViewType)
Public method SetTypeId Sets the DirectShapeType for the DirectShape element.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method UpdateExternallyTaggedGeometry Updates the externally tagged geometry object in the DirectShape.
Top
Remarks
DirectShape is not a replacement for "real" Wall, Roof, Window, etc. It would typically be used where there is not enough information to create, e.g., a Wall, or full functionality of a Wall object is not needed. Some category-specific functionality may be available. If you need to modify a shape held by a DirectShape object, use Revit Geometry API, and then store the modified shape back to the DirectShape object.
See Also