ValidateExportOptions Method


INavisworks Exporter Validate Export Options Method

Determines if the inputs are valid, and returns an error message if not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
bool ValidateExportOptions(
	Document document,
	string folder,
	string name,
	NavisworksExportOptions options,
	out string exceptionMessage
)

Parameters

document Document
The document to export.
folder String
The folder path.
name String
The file name.
options NavisworksExportOptions
The export options.
exceptionMessage String
The message to show in the exception thrown. This is not an end-user visible message, it is a developer message, and does not have to be localized. Ignored if the function returns true.

Return Value

Boolean
True if the options are valid, false otherwise.
See Also