GroundConductorSizeSet Class


Ground Conductor Size Set Class

A set that contains GroundConductorSizes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical GroundConductorSizeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GroundConductorSizeSet : APIObject, 
	IEnumerable

The GroundConductorSizeSet type exposes the following members.

Constructors
Name Description
Public method GroundConductorSizeSet Initializes a new instance of the GroundConductorSizeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of GroundConductorSizes that are in the set.
Top
Methods
Name Description
Public method Clear Removes every GroundConductorSize from the set, rendering it empty.
Public method Contains Tests for the existence of a GroundConductorSize within the set.
Public method Erase Removes a specified GroundConductorSize from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified GroundConductorSize into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also