UpdateFromIFC Method


Revit Link Type Update From IFC(Document, String, String, Boolean) Method

Updates a Revit link type from an IFC file and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool UpdateFromIFC(
	Document document,
	string ifcFilePath,
	string revitLinkedFilePath,
	bool recreateLink
)

Parameters

document Document
The document that contains Revit link.
ifcFilePath String
The path of the IFC link to load. This must be a full path.
revitLinkedFilePath String
The path of the Revit file to create to hold the IFC information. This must be a full path.
recreateLink Boolean
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.

Return Value

Boolean
Returns true if the update succeeded, false otherwise.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The input path "ifcFilePath" does not represent an IFC file. -or- The document is a cloud model.
ArgumentNullException A non-optional argument was null
FileAccessException The model cannot be accessed due to lack of access privileges.
FileArgumentNotFoundException There is not a valid Revit file at ifcFilePath's location
InvalidOperationException The file is not allowed to access. -or- Revit cannot customize worksets for this model.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially. Note that the IFC file will not be stored directly in the document; it will instead by stored in an intermediate Revit document, whose location is given by revitLinkedFilePath.
See Also